Utah's forum for General Motors performance vehicles
 
HomeCalendarFAQSearchRegisterLog in
Search
 
 

Display results as :
 
Rechercher Advanced Search
Latest topics
» Cobalt stuff for sale
Fri Sep 07, 2012 12:00 pm by littleasian90

» Tachout's Build Thread
Sun Sep 02, 2012 11:10 pm by Tachout

» My request
Wed Jun 27, 2012 4:05 am by Shawn

» Cobalt SS exhaust manifold stud needed
Sat Jun 16, 2012 4:10 pm by littleasian90

» New member from bluffdale UT
Mon Apr 30, 2012 10:08 pm by colodude18

» S14 Silvia SR20DET swap
Wed Apr 18, 2012 3:24 pm by littleasian90

» MT ET Drag Tires $10.00 Each
Thu Apr 12, 2012 1:32 pm by Tachout

» Business card design
Tue Apr 10, 2012 2:48 am by Shawn

» Wide open wednesday at miller motorsports park 2012
Mon Apr 09, 2012 5:34 pm by Shawn

November 2018
SunMonTueWedThuFriSat
    123
45678910
11121314151617
18192021222324
252627282930 
CalendarCalendar

Share | 
 

 I blew up my turbo!

Go down 
AuthorMessage
Xray
Just Joined
Just Joined


Posts : 3
Join date : 2011-08-01

PostSubject: I blew up my turbo!   Wed Aug 24, 2011 5:33 pm

Back to top Go down
goldenfoot05
Noob
Noob


Posts : 19
Join date : 2011-07-29

PostSubject: Re: I blew up my turbo!   Fri Aug 26, 2011 9:34 am

Good thing it was the exhaust side turbine. I would imagine it was just a defect in the blade. If it was a piece of exhaust valve it wouldnt run very smooth. Is the o2 sensor they replaced before or after the turbo. If before maybe something came off the o2 sensor and thats what lodged in the blade. Then again the blade breaking may have damaged the o2 sensor if it was after the turbo.
Back to top Go down
Xray
Just Joined
Just Joined


Posts : 3
Join date : 2011-08-01

PostSubject: Re: I blew up my turbo!   Fri Aug 26, 2011 10:55 am

It was the wideband O2 which is after the turbo I think. So prly a piece of the impeller hit it.
Back to top Go down
Sponsored content




PostSubject: Re: I blew up my turbo!   

Back to top Go down
 
I blew up my turbo!
Back to top 
Page 1 of 1
 Similar topics
-
» MCX Turbo kit 900XP 148rwhp
» They blew it up! God damn them all to hell!
» 15.5 hp turbo cooled craftsman briggs and stratton wont start
» To turbo or not to turbo>>
» First factory turbo Sxs!!

Permissions in this forum:You cannot reply to topics in this forum
UtahGMPerformance :: General :: Repairs and Problems-
Jump to: